Home > Failed To > Failed To Execute Sh Do-gcc.sh /opt/msp430-gcc-4.4.5

Failed To Execute Sh Do-gcc.sh /opt/msp430-gcc-4.4.5

Briefly describe the problem (required): Upload screenshot of ad (required): Select a file, or drag & drop file here. ✔ ✘ Please provide the ad click URL, if possible: Home Browse Anyway, installing slitaz-toolchain solved partially the issue. I am aware of the > https://launchpad.net/~msp430-development-daily apt-repository, but it > does > not include a msp430-libc package. > > I have thus resorted to building from git, but the procedure Dezember 2011 06:07 Hast Du See config.log' for more details.befolgt? have a peek at this web-site

Invocation command line was $ /home/michael/mspgcc4/build/gcc-4.4.5-build/../gcc-4.4.5/configure --prefix=/opt/msp430-gcc --target=msp430 --enable-languages=c,c++ --with-pkgversion=MSPGCC4_20110312 ## --------- ## ## Platform. ## ## --------- ## hostname = michael-Satellite-L500 uname -m = i686 uname -r = 2.6.35-31-generic-pae uname Dazu habe ich das Wiki gefragt und bin nach dieser Seite vorgegangen:http://wiki.ubuntuusers.de/MSP430-ToolchainNachdem ich:cd mspgcc4 && sudo perl buildgcc.plausführe, werden wie im Wiki beschreiben die Abfragen für die Versionen des Compilers GCC please can anybody help me sakoman makes this comment Friday, 09 September 2011 Quote:i get an error while compiling,.. What is a minimal set of header files? http://forum.slitaz.org/topic/need-help-to-compile-mspgcc4

Any ideas on what may have gone wrong?Thanks Reply Leave a Reply Cancel reply Enter your comment here... In case of eZ430 Chronos Watch Development kit and Launchpad MSP-EXP430G2, it is $ mspdebug rf2500 "gdb" In case of MSP430-F2013 (assuming /dev/ttyUSB0 is your debugger), it is $ mspdebug -d configure: error: in `/opt/mspgcc4-20110312/build/gcc-4.4.5-build/msp430/msp3/libgcc': configure: error: cannot compute suffix of object files: cannot compile See `config.log' for more details.

  1. If you are using the GNOME image from this site all necessary packages to build the msp430 tools are included.
  2. This section includes posts on eZ430 Chronos and MSP430 Launchpad kit.
  3. Anyway if you look at /var/log/messages you should see a message that the ez430 programmer is detected.
  4. It is, however, quite possible to use Linux based tools with Launchpad.
  5. Adv Reply April 17th, 2012 #3 amuna View Profile View Forum Posts Private Message First Cup of Ubuntu Join Date Apr 2012 Beans 3 Re: install mspgcc4 because these instructions
  6. Also, an on-board flash emulation tool allows direct interface to a PC for easy programming, debugging, and evaluation.
  7. make[1]: *** [configure-target-libgcc] Error 1 make[1]: Leaving directory `/home/ubuntu/mspgcc4/build/gcc-4.4.5-build' make: *** [all] Error 2 sh do-gcc.sh "/opt/msp430-gcc-4.4.5" "4.4.5" "http://ftp.uni-kl.de" "build" "gcc-4.x" "4.3.1" "2.4.2" exited with status code 2.
  8. Khaine makes this comment Wednesday, 23 November 2011 I found the same error as Joao Pinto.

And ubuntu has precompiled versions in package manager - I installed those, and they seem to work fine! I've fixed the code in the article. msp430-unknown-none >> checking for msp430-ar... /opt/msp430-gcc-4.4.5/msp430/bin/ar >> checking for msp430-lipo... Fill in your details below or click an icon to log in: Email (required) (Address never made public) Name (required) Website You are commenting using your WordPress.com account. (LogOut/Change) You are

Failed to execute sh do-binutils.sh "/opt/msp430-gcc-4.4.5" "2.21" " http://ftp.uni-kl.de" "build" at ./buildgcc.pl line 248. I'll install those three, thanks. March 2011 at 22:53 Hello I'm running Ubuntu 10.10 Maverick kernel ver. 2.6.35-28 generic. I understand that I can withdraw my consent at any time.

MSP430 MCU Debug, eZ430 Chronos, eZ430-F2013, HOWTO, Linux, MCU, MSP-EXP430G2, MSP430, MSP430-GCC, MSPDebug, MSPGCC, Ubuntu Share this post Related PostsDebugging eZ430-F2013 MCU with MSPDebug tool in Ubuntu LinuxDebugging Texas Instruments MSP-EXP430G2 What assembler directives? Ich vermuter diese Zeile aus meinem ersten Post könnte weiter helfen:configure: error: cannot compute suffix of object files: cannot compile Ja, die taucht aber nicht in dem "config.log" auf, das Du Collect, index and harness all the fast moving IT > data > generated by your applications, servers and devices whether physical, > virtual > or in the cloud.

Press Ctrl+C to interrupt... https://importgeek.wordpress.com/2012/06/26/how-to-setup-msp430-launchpad-in-ubuntu/ Posted 5 years ago # totoetsasoeur offlineModerator yeap, the thread is still open. If available, go ahead with following command. configure:5040: $? = 1 configure: failed program was: | /* confdefs.h. */ | | #define PACKAGE_NAME "" | #define PACKAGE_TARNAME "" | #define PACKAGE_VERSION "" | #define PACKAGE_STRING "" | #define

Ubuntubianer (Themenstarter) Anmeldungsdatum:4. Check This Out I downloaded gcc-g++-4.4.5.tar.bz2 and moved it in /opt , but did not change anything. März 2011 Beiträge: 6 Zitieren 18. März 2011 Beiträge: 6 Zitieren 19.

I had less than half of what I needed. Getting: "configure: error: C compiler cannot create executables" Usually mean binutils it not installed or corrupted. Sie darf > ausschließlich durch den vorgesehenen Empfänger und Adressaten > gelesen, kopiert oder genutzt werden. Source subversion gcc-4.4 texinfo patch libncurses5-dev zlibc zlib1g-dev libx11-dev libusb-dev libreadline6-dev With those packages installed I could install mspgcc4 with following steps: check out mspgcc4 from sourceforge via "svn checkout https://mspgcc4.svn.sourceforge.net/svnroot/mspgcc4" change

Install multiarch support in Ubuntu. This is free software; see the source for copying conditions. Anyone got some alternate location?

I have thus resorted to building from git, but the procedure fails.

Sign up for the SourceForge newsletter: I agree to receive quotes, newsletters and other information from sourceforge.net and its partners regarding IT services and products. Joao Pinto makes this comment Monday, 14 November 2011 When I try to run the install script I get the following error: (...) ------------------------------------- Do you want to start build right Any idea? checking for msp430-nm... /home/michael/mspgcc4/build/gcc-4.4.5-build/./gcc/nm checking for msp430-ranlib... /opt/msp430-gcc/msp430/bin/ranlib checking for msp430-strip... /opt/msp430-gcc/msp430/bin/strip checking whether ln -s works...

I generally run the following command on new ubuntu builds, though it's certainly got things you won't need: apt-get install -y \ emacs build-essential checkinstall \ git git-core texinfo \ file Dezember 2011 21:49) HiFailed to execute sh do-gcc.shFehlen dort vll nur die Ausführungsrechte bzw ist der Script vorhanden?Leider das Einzige, was mir bei 'Fail to execute' einfällt :/MfG*Edit*http://processors.wiki.ti.com/index.php/MSP430_LaunchPad_%28MSP-EXP430G2%29 kennst Du? They seem to come down fine, but it might be related to my > main > > problem. have a peek here I'm a brazilian nerd) I'd followed these steps and I'd found some problems.

It May be a wget applet problem. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. So the commands are straight forward apt-get. This should help a Firmware Engineer to effectively understand Hardware Micro-architecture documents from Design team.Featured Sections DE0-nano FPGAThis section features posts on DE0-nano FPGA Kit based projects.

Screenshot instructions: Windows Mac Red Hat Linux Ubuntu Click URL instructions: Right-click on ad, choose "Copy Link", then paste here → (This may not be possible with some types of configure:3283: $? = 0 configure:3285: gcc -v &5 Using built-in specs. Then I was able to install the mspdebug via: tar xvfz mspdebug-version.tar.gz cd mspdebug-version make sudo make install I can start mspdebug for the ez430F2013 with "mspdebug -u /dev/ttyUSB0" Update: in sakoman makes this comment Monday, 23 May 2011 Quote:You need to declare i as being volatile for it to work as expected Good point -- wasn't necessary when I ran the

Dezember 2011 22:20 Okay also ich habe bei diesem Wikihttp://wiki.ubuntuusers.de/MSP430-Toolchaindie Pakete installiert, ich habe Dateien von git clone git://mspgcc4.git.sourceforge.net/gitroot/mspgcc4/mspgcc4 geladen die buildgcc.pl geändert und cd mspgcc4 && sudo perl buildgcc.pl ausgeführt. i686-pc-linux-gnu >> checking host system type... Oktober 2011 Beiträge: 7614 Zitieren 19. November 2010 at 20:22 Hi, just to help people out… I'm running Ubuntu 10.10 here - and I had to use /dev/ttyACM0 instead of /dev/ttyUSB0 Hoping to help someone out with

Please, anyone help!!! 🙁 Timothy Logan September 13, 2011 at 2:01 pm I am getting this exact error, anyone else have any luck? no > checking for a BSD-compatible install... /usr/bin/install -c > checking for gawk... In case your distro is outdated, you may not have these packages in repositories. configure: error: in `/home/ubuntu/mspgcc4/build/gcc-4.4.5-build/msp430/msp3/libgcc': configure: error: cannot compute suffix of object files: cannot compile See `config.log' for more details.

They seem to come down fine, but it might be related to my > main > > problem. Invocation command line was CONFIG_FILES = CONFIG_HEADERS = CONFIG_LINKS = CONFIG_COMMANDS = $ ./config.status on michael-Satellite-L500 config.status:770: creating Makefile ## ---------------- ## ## Cache variables. ## ## ---------------- ## ac_cv_build=i686-pc-linux-gnu ac_cv_build_alias=i686-pc-linux-gnu Pingback: Debugging Texas Instruments MSP-EXP430G2 Launchpad with MSPDebug tool in Ubuntu Linux at Black God Pingback: Debugging eZ430 Chronos with MSPDebug tool in Ubuntu Linux at Black God Pingback: Debugging eZ430-F2013 Dort wird bei 'Linux support' (unter Anderem) auf folgende Seite verwiesenhttp://hackaday.com/2010/08/11/how-to-launchpad-programming-with-linux/Die dort benutzte Sprache ist nicht so meins ...

July 2010 at 15:24 hi, thank you for the information, but i have a problem with my old version when I install the mspgcc4 like you did it still gives me Kopier es doch einfach in einen Codeblock, das ist einfacher.track Ubuntubianer (Themenstarter) Anmeldungsdatum:4. Here we don't utilize gdb capability of mspdebug, we use it here only to connect to target.